2009/02/06

Ubuntuの公式レポジトリで微妙にRのバージョンが古い件を解決する

いつもソースからコンパイルしていましたが、なんで今まで気付かないかったのか。CRANを apt の sources.listに登録すればいいのでした。あたりまえすぎですが自分用のメモってことで書いておく。
<<<
sudo jed /etc/apt/sources.list
# CRAN
deb http://cran.r-project.org/bin/linux/ubuntu intrepid/
>>>
鍵を登録して、
<<<
gpg --keyserver subkeys.pgp.net --recv-key E2A11821
gpg -a --export E2A11821 | sudo apt-key add -
>>>
インストール祭り開始!
<<<
sudo apt-get update
sudo apt-get install r-base
sudo apt-get install "r-cran-*"
>>>